Back to overview
Downtime

Paddle (billing vendor) — active incident

Apr 21, 2026 at 11:07am UTC
Affected services
Billing & Payments

Resolved
Apr 21, 2026 at 2:27pm UTC

Paddle has recovered: All systems operational. Billing and checkout are fully operational.

Created
Apr 21, 2026 at 11:07am UTC

Our billing vendor (Paddle) is reporting an active incident: Webhook & Email Delivery (Identified). Checkout, plan upgrades, and subscription changes may be affected. The core Flexivity AI product remains fully operational. Live Paddle status: https://paddlestatus.com