Back to overview
Downtime

Paddle (billing vendor) — active incident

Apr 28, 2026 at 3:47pm UTC
Affected services
Billing & Payments

Resolved
Apr 30, 2026 at 2:12pm UTC

Paddle has recovered: All systems operational. Billing and checkout are fully operational.

Created
Apr 28, 2026 at 3:47pm UTC

Our billing vendor (Paddle) is reporting an active incident: New Sellers might be unable to access Retain settings and the ProfitWell Metrics dashboard (Investigating). Checkout, plan upgrades, and subscription changes may be affected. The core Flexivity AI product remains fully operational. Live Paddle status: https://paddlestatus.com