Back to overview
Downtime
Paddle (billing vendor) — active incident
May 20, 2026 at 8:07am UTC
Affected services
Billing & Payments
Resolved
May 20, 2026 at 10:07am UTC
Paddle has recovered: All systems operational. Billing and checkout are fully operational.
Affected services
Created
May 20, 2026 at 8:07am UTC
Our billing vendor (Paddle) is reporting an active incident: Maintenance: Scheduled Maintenance - Sandbox Environment (In progress). Checkout, plan upgrades, and subscription changes may be affected. The core Flexivity AI product remains fully operational. Live Paddle status: https://paddlestatus.com
Affected services