Back to overview
Downtime
Paddle (billing vendor) — active incident
Jun 1, 2026 at 8:42am UTC
Affected services
Billing & Payments
Resolved
Jun 1, 2026 at 9:02am UTC
Paddle has recovered: All systems operational. Billing and checkout are fully operational.
Affected services
Created
Jun 1, 2026 at 8:42am UTC
Our billing vendor (Paddle) is reporting an active incident: Card payment issues on Paddle Billing and Paddle Classic checkout (Monitoring). Checkout, plan upgrades, and subscription changes may be affected. The core Flexivity AI product remains fully operational. Live Paddle status: https://paddlestatus.com
Affected services